Site issues

Posted by ,

Brickset is currently experiencing some technical problems which are causing long waiting times for many users. We are working on the problem, and we hope that full service will be resumed shortly.
Apologies for the inconvenience, and thank you for your patience.

The Brickset Team

12 comments on this article

Gravatar
By in United States,

hey people just today is a lego build at toysrus ending at 2:00 pm. est time .I got my set

Gravatar
By in United Kingdom,

"Causing long waiting times"- earlier I couldn't access the site at all, but now don't seem to have a problem, so whatever you did, well done :)

Gravatar
By in United States,

Yeah, I had a problem a few hours ago; the main site didn't load. I also had a slow loading time coming to this article to write this comment. But hey, I can't complain. I'm not paying for it, nor am I highly involved in it. ;)

Gravatar
By in United Kingdom,

i couldn't get on the site half of the time but i still got on a few times when i was trying to get on here.
better then nothing i guess.

Gravatar
By in United Kingdom,

lego613master yeah i can't complain. this is a great website with cool features i really like how you can keep
track of you're collection.i couldn't get on the site half of the time but i still got on the site.

Gravatar
By in United States,

I even had to wait up to fifteen minutes. But it's working perfectly fine now.

Gravatar
By in United States,

I accessed Brickset at about 7 AM Eastern Daylight Time and received a 403 Error
Refreshed the site a couple of times, but got the same problem

Around 3:30 EDT, it worked fine

Gravatar
By in United Kingdom,

Whatever the cause it does seem better now so it might have been a transient issue. I'll be back from vacation in 8 hours or so and I'll check it out when I get home.

Gravatar
By in United States,

It was either taking forever to load or not loading at all this morning, seems back to normal speeds now though.

Gravatar
By in United Kingdom,

Still very slow accessing the site 10:30am BST today. Took about a minute for the front page to load up this morning. While not as bad as yesterday, the problem's still there for me.

EDIT: 11:30am BST, now seems to be running at normal speeds for me.

Gravatar
By in United Kingdom,

Yes it is working but very slowly for me too.

Gravatar
By in United Kingdom,

It should be OK now. The ISP found a problem with the computer that hosts the Brickset virtual server.

Commenting has ended on this article.

Return to home page »